Author Topic: Find duplicates acting strange  (Read 2714 times)

0 Members and 1 Guest are viewing this topic.

houkouhaikai

  • Newbie
  • *
  • Posts: 24
    • View Profile
Find duplicates acting strange
« on: May 14, 2006, 01:16:48 PM »
The find duplicate button is showing...rather strange behavior.

Example: I chose to edit all entries in all lessons that are 'unknown' or 'bad'

The search duplicates button is not available. Seems like there are no duplicates. But that is not true. Then I let stackz sort it, with reading as criteria. No change in the button.
But now I scroll down and find my 蝦, which I added twice on purpose.

No change in the button. Now I change the sorting by clicking on Entry.
And see there, it becomes available.

Now I click it...and yeah! It worked.


Um...but this is quite strange. I only happened to find out that it works like this by accident. Maybe this should be...changed a bit?
For example by making it work regardless of the sorting...or instead of graying the button out make it automatically sort for entry and then perform the duplicate search.
If that all is impossible then a note at the mouseover that you have to click entry first would probably help the users.
« Last Edit: May 14, 2006, 01:31:59 PM by houkouhaikai »

Chris

  • Administrator
  • Sr. Member
  • *****
  • Posts: 429
    • View Profile
Re: Find duplicates acting strange
« Reply #1 on: May 14, 2006, 08:47:34 PM »
If I am correct, then your post can be resumed like this:
Duplicate entries are only detected correctly after manually sorting the entries according the first column.

I checked it, and it seems that you are right. On slow computers the detection of duplicates is time consuming, especially with long lists - that's why the algorithm is only supposed to run if really needed. Of course it should run when the dialog is opened...

I'll fix that soon, in the meantime simply use the workaround as indicated above.

Thanks for posting!