The Stackz Concept > General Discussion

Pinyin tone transformation

(1/1)

Nora:
I hope I'm not double-posting this question, but I couldn't find anything with the search.

I'm using Stackz to learn Japanese and Chinese vocabulary and like it a lot, but there's a thing I couldn't figure out yet. In some files, Stackz is transforming Pinyin tone numbers, in some files not. For example, when I write in the field for "Reading"

hui2dang4

in some cases it just stays that way, in other cases it changes to

hudng.

Where can I setup that it always changes to hudng?

Thanks in advance,
Nora

Chris:
The tone marks are displayed as pinyin if the attribute of interest uses the "Chinese Simplified" Stackz Language. You can define the Stackz Language for every attribute in the "Entries" Tab of the File Options dialog (menu Options - File Options).

The pinyin conversion is enabled if the font used by the Stackz Language is set to the "Chinese GB 2312" script, which is the case for the built in "Chinese Simplified" Stackz Language. If you define your own language, please specify a font using the said script in order to see the pinyin tone marks.

Note: The attributes can't be directly linked to a certain font file because the same Stackz file might be used on multiple platforms (Windows, Pocket PC, Palm OS) which have different font files and even different font technologies. The attributes are therefore linked to a "Stackz Language" instead, which then points to the correct font file the platform.

Nora:
Thanks for your fast answer. When I read it, I already had the feeling that everything is set up just like you told me to. I checked again and as far as I see, it's correct. I made a screenshot for you to see if that's really what you meant. http://www.nortels.de/krams/stackzscreenshot.jpg
So although I think I use the correct settings, it's still not working. Could you point out the mistake I made?

Thanks
Nora

Chris:
Seems to be correct...

So if you type in new text in one of the chinese attributes, it should display pinyin. Please describe in more detail where it is correct, and where not so I can try to find out what is going on.

Nora:
I just experimented a little bit and I think I know now what the problem was. As you can see at my screenshot, the checkbox is ticked at "Attribute 1" and the "file language" is shows the stackz-logo. If I tick "Attribute 2", the file language switches to Chinese and the pinyin are shown correctly.

Navigation

[0] Message Index

Go to full version